Issues with SMS sending
Incident Report for Alma
Postmortem

Summary

Between 30/03/2023 13:22 CEST and 06/04/2023 10:08 CEST, for SMS sent through one of our providers.

  1. If the link was the last element of the SMS, it would have been broken.
  2. SMS failed to be sent between 22h and 8h CEST

Most SMS concerned : payment reminders and other noncritical SMS.
In some cases, this incident could have impacted the user’s ability to go through a payment as expected.

  • One time password authentications
  • Onboarding links for ID verification
  • Payment links sent from our point-of-sale solution

All of these actions could be retried at that time, and would have had high chances of going through an alternative provider when doing so.

Root cause

The account settings from one of our SMS providers were changed to "Marketing purposes" which made our SMS subject to french regulation on marketing SMS, even for our transactional SMS.

Posted Apr 24, 2023 - 11:57 CEST

Resolved
Between 30/03/2023 13:22 CEST and 06/04/2023 10:08 CEST we encountered issues sending some SMS.
The incident has been resolved. All our services are back to normal and you can now use our services as normal.
Thank you for your patience and feedback.
Posted Apr 06, 2023 - 10:08 CEST