Issue under investigation
Incident Report for Alma
Resolved
We no longer observe abnormal delays on SMS deliveries
Posted Oct 31, 2023 - 16:10 CET
Investigating
We are experiencing delays delivering SMS via our SMS providers and are currently monitoring the issue. We will provide updates as we learn more information.
Posted Oct 31, 2023 - 11:40 CET
This incident affected: Payments (Buy now pay later).