Eligibility API failure
Incident Report for Alma
Postmortem

Summary

On 18/04/2023 Eligibility API had an outage from 11:55 to 12:06 CEST. This is the first API endpoint called in most payment flows. It is notably used by our Widget and most e-commerce integrations. Therefore a lot of users were unable to properly start their payment journey.

Root cause

The  18/04 release introduced a new database user for our internal API. The permissions granted to the user did not replicate correctly the permissions validated in the lower environments due to different parameters during the release. This prevented our eligibility endpoint from getting some required data and therefore created an outage.

Posted Apr 24, 2023 - 11:39 CEST

Resolved
On 18/04/2023 Eligibility API had an outage from 11:55 to 12:06 CEST
The incident has been resolved. All our services are back to normal and you can now use our services as normal.
Thank you for your patience and feedback.
Posted Apr 18, 2023 - 12:05 CEST
Identified
Some of our services are currently unavailable. We are working to mitigate and fix the problem as quickly as we can.
We sincerely apologise for this situation.
Posted Apr 18, 2023 - 11:54 CEST
This incident affected: Payments (Buy now pay later, Credit payments) and In-store tools (Point-of-sale client).