Degraded services
Incident Report for Alma
Resolved
We are no longer experiencing SMS delivery delays when sending messages.
Posted Mar 05, 2024 - 10:31 CET
Investigating
We are observing delays in SMS and email sending, we are investigating the issue.
Posted Mar 05, 2024 - 10:00 CET