The issue has been solved, payouts are executed correctly and in expected times.
Posted Jun 10, 2025 - 18:04 CEST
Investigating
We have identified an issue with some of our services, we are working to fix the problem as quickly as we can. Merchants may encounter some delay receiving their payouts. We sincerely apologise for this inconvenience.
Posted Jun 10, 2025 - 15:29 CEST
This incident affected: Payouts (Standard payouts, Direct integration payouts).