The incident has been resolved. All our services are back to normal and you can now use our services as normal. Thank you for your patience and feedback.
Posted Jan 30, 2025 - 16:54 CET
Monitoring
We have identified an issue with some of our services. We identified the source of the issue and implemented a mitigation, to reduce the issue impact.
Posted Jan 30, 2025 - 16:45 CET
This incident affected: Payments (Buy now pay later, Credit payments).