Resolved
Our engineering team has mitigated the issue. All services are back up and running.
Identified
Our engineering team has identified an issue with our services impacting Adyen terminals. We have identified the problem, and taking steps to mitigate the issue.