Resolved
Our teams have identified and fixed an issue with our payment processing. Our systems are fully operational again.
Investigating
Our teams have identified an issue with our systems, resulting in degraded payment processing performances. We are working on identifying and solving the issue.