Resolved
The incident has been resolved. All our services are back to normal and you can now use our services as normal since 11h51
Thank you for your patience and feedback.
Monitoring
A workaround is in place, payments are being processed again. We are actively monitoring.
Identified
Nepting payments are still not processed.We are working on a workaround to mitigate the issue.
All other payments types are working as expected.
Investigating
We have identified an issue with some of our services due to an infrastructure change. We are working to fix the problem as quickly as we can.We sincerely apologise for this inconvenience.